Xenforo 2.1 Upgrade Questions/Issues

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

xl97

Sr Member
^ that happens JUST when using the back button on this forum only?? (very odd as that is a browser behavior)

perhaps a session thing or something?
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

Dakota

Active Member
RPF PREMIUM MEMBER
I have a question.

Is the splash page really necessary? Just from a user experience standpoint, it offers little other than an extra hoop to jump through to view the forum. A minor annoyance at worst, but still one that definitely hurts the user experience which is why splash pages fell out of style long ago and aren't seen in common use with current web standards.. I know it will hurt the website overall in SEO score and optimization as the main bulk of the website is nested in ./forums/ rather than just being the website index/root directory.

I know changing the structure can be a pain, especially if you use CDNs, but it's pretty straight forward.

All in all, it won't stop me from using the site of course, and the decisions made by the site staff will be respected. I just thought I'd offer my own humble perspective. Thanks for your time.
 

xl97

Sr Member
You could just as easily put in a redirect in the .htaccess file (or other means).. to immediately put people at the forum index.

I understand the reason, to install the software/platform into a sub directory (the forum software I imagine has tons of files and directories..etc..etc).. so having it all in one sub-directory in the _root of the domain make sense..


This also allows the _root of the domain to be something else eventually.

A store front
A portal to jump/link to other areas of the site
Advertisements in the future..etc

So in the future.. it may have a purpose... but now that it isnt currently being used for anything, it should just redirect us all to the forums index page.
 

Dakota

Active Member
RPF PREMIUM MEMBER
You could just as easily put in a redirect in the .htaccess file (or other means).. to immediately put people at the forum index.

I understand the reason, to install the software/platform into a sub directory (the forum software I imagine has tons of files and directories..etc..etc).. so having it all in one sub-directory in the _root of the domain make sense..


This also allows the _root of the domain to be something else eventually.

A store front
A portal to jump/link to other areas of the site
Advertisements in the future..etc

So in the future.. it may have a purpose... but now that it isnt currently being used for anything, it should just redirect us all to the forums index page.
This is a good point.

I'm only familiar with Invision Power Board (highly recommend), not so much experience with Xenforo. But IPB actually generates the .htaccess for you in the AdminCP, so I would assume Xenforo has something similar. It still meets web standards and SEO standards too!
 

eethan

Sr Member
RPF PREMIUM MEMBER
Hi, this might be a silly issue to report but it is kind of annoying to me and maybe to others. For some reason, everytime you change page, the header image is reloading and first it disapears. As a result, all the page goes up, and then the header loads and everything goes down again, in the meantime you want to click on something and you click on something else. It would be great if this could not reload or at least stay at a fixed height so it doesn't change the page content while loading.
thanks a lot (y)
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

Art Andrews

Community Owner
Community Staff
Hi, this might be a silly issue to report but it is kind of annoying to me and maybe to others. For some reason, everytime you change page, the header image is reloading and first it disapears. As a result, all the page goes up, and then the header loads and everything goes down again, in the meantime you want to click on something and you click on something else. It would be great if this could not reload or at least stay at a fixed height so it doesn't change the page content while loading.
thanks a lot (y)
Let me take a look at how it is loading and we will see what can be done.
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

AJK001

Sr Member
I just noticed that all of the threads in forums are not highlighted like it would be if I had read them or marked everything as read. Is this something new or something gone wrong?
 
Last edited:

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

Top