Wand Company Phaser Discontinued???

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.


Cameron

Sr Member
RPF PREMIUM MEMBER
It seems these are no longer available and are selling for 300-500 on the bay right now! Anyone know why they stopped making them?
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

JiminSTLouis

Sr Member
The phaser has probably gone through its product life cycle and sales/inventory were at levels that couldn’t support continued production.
 

AJK001

Master Member
According to what they said a few years back at the TPZ, this was even before the Communicator came out, they were only going to do a couple of runs. I don't remember if that meant a couple of more or a couple in total. As we have seen with their other products they only make them for so long and now you can't even get replacement 10th Doctor Sonics or the batteries for them.
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

RayR

Well-Known Member
RPF PREMIUM MEMBER
According to what they said a few years back at the TPZ, this was even before the Communicator came out, they were only going to do a couple of runs. I don't remember if that meant a couple of more or a couple in total. As we have seen with their other products they only make them for so long and now you can't even get replacement 10th Doctor Sonics or the batteries for them.
That's true. But the part about not getting batteries is not their fault. The UK change their laws on shipping anything with lithium batteries. I ordered a few replacement batteries from Ali express. It took about 6 weeks to get here, and it was very inexpensive.
 

Fett_Ish

Sr Member
I got a reply on another thread the other day, it was very curt with no real information, but my thought was they don't have the license anymore. Tha would stink as I was hoping for a tricorder/router or portable hard drive....
 

Prologic9

Active Member
They just came out with the rock/phaser thing a few months ago, I doubt it's a licensing issue.

Things like this just don't stay in production forever.
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

Rylo

Master Member
RPF PREMIUM MEMBER
File that under **** you could've mentioned when we talked last! Ugh!!

Wait, you grabbed the comms, not the phasers. Got it! LOL
 

Bodie27

Active Member
Hope someone sees this. My phasers sound seems to not work or work erratically producing only one sound effect...can anyone advise. Kept on display and charged
 

TVThemeGuy

New Member
Hope someone sees this. My phasers sound seems to not work or work erratically producing only one sound effect...can anyone advise. Kept on display and charged
Clean the contacts on the bottom of your P1. They've probably become oxidized. I had an identical issue with mine. I used a toothpick to carefully scrape the contacts, then alcohol and a Q-tip to remove any residue. All functions restored.
 

Your message may be considered spam for the following reasons:

  1. Your new thread title is very short, and likely is unhelpful.
  2. Your reply is very short and likely does not add anything to the thread.
  3. Your reply is very long and likely does not add anything to the thread.
  4. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
  5. Your message is mostly quotes or spoilers.
  6. Your reply has occurred very quickly after a previous reply and likely does not add anything to the thread.
  7. This thread is locked.

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

Top