QMX polystone Phaser fix?

Discussion in 'General Modeling' started by 22 Stars, Jan 27, 2012.

  1. 22 Stars

    22 Stars Member

    Trophy Points:
    181
    Hey guys, long story short my QMX metal plated Phaser, made of polystone, dropped and broke, and I was wondering what is the best adhesive to put it back together?
     
  2. robn1

    robn1 Master Member

    Trophy Points:
    3,355
    Super glue or epoxy.
     
  3. 22 Stars

    22 Stars Member

    Trophy Points:
    181
    Thanks Robn1, I appreciate it. Just got a small tube of the super glue gel, and it seems to be working like a charm.

    That'll teach me for putting the phaser on my desk, where my wife puts her coat on in the morning :)
     
  4. robn1

    robn1 Master Member

    Trophy Points:
    3,355
    Ouch! Yeah, sounds like they could have used a better material for this. Did it come apart at the seem or did it break?
     
  5. 22 Stars

    22 Stars Member

    Trophy Points:
    181
    A little of both, rob, the handle assembly broke, and the bottom tailfin also broke away from that, but the front extension, which the the bottom cowl to the emitter array broke off a the seam, where it attached to the handle. That assembly is pretty seamless, so no worries there, but I now have two hairline cracks across the bottom of the tail chrome. Oh well.

    I have a spare boxed somewhere if I need it, and I will say this for polystone, it cracks pretty smoothly, so no big chunks missing.
     

Share This Page