Art Asylum Phaser Troubleshooting.

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.


Johnny Adama

New Member
Looking into a little insight from anyone who has bought the Classic Star Trek Phaser from Art Asylum.
I got one of these for Christmas. It seemed to work ok in "display mode" while it was in the box. BUT as soon as I removed the plastic tab to bring it out of display mode, the phaser went completely dead. Not a light, not a sound, nothing. I do not know a lot about electronics, so I can not fathom as to why removing the tab as instructed would completely shut this thing down.

Yes, I did run through the basics such as replacing the batteries, but the gun is completely dead. Just for the hell of it, I managed to get that plastic tab slid-back inside of the phaser...and it started to work again on the display mode!

Obviously while it is locked-on to display mode, you can not adjust the sound and light functions...it is locked onto the one short burst for store display.

I'd like to get this thing running as it should. Has anyone else encountered an issue similar to this with the Art Asylum Classic phaser?
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

robn1

Master Member
Never seen this. My first thought was that the batteries were displaced when you pulled the tab, but if you replaced them that would have fixed it. It could be the selection wheel isn't making good contact. Have you tried turning it while firing?
 

Johnny Adama

New Member
Yes. I Tried to adjust the knobs while firing. Nothing happens at all. It seems that the only time this phaser does anything is if that plastic store tab is left in place. And of course that is just the limited store quick shot function and not the full range of sounds. Somehow the whole phaser just shuts down when that tab is removed. It seems like it should be an easy solution, but I am completely stumped.
 

Robiwon

Master Member
Gone but not forgotten.
I wonder if there is a demo mode switch? Pull the tab, flip the switch type of thing. It's been a while since I had mine. Take the batteries out again and see if there is a small switch under where the batteries sit.
 

DoctorEight

Active Member
There is no demo mode on the Phaser.

Are you trying the correct trigger button on the Type I unit?
 
Last edited:

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

Johnny Adama

New Member
When I tried changing the batteries I did take note of the fact that there is no demo mode switch.
As far as pushing the correct trigger button goes, yes I am pushing the correct one. It's the damnedest thing I have ever seen....pull-out the store-tab and the gun goes completely dead.
I am tempted to pull it apart...but I just don't know enough about electronics to do it. That's why I was sort of half hoping that I was dealing with a common issue and see if someone could give me a quick walk-through.
 

robn1

Master Member
Forgive me if this sounds like a "is it plugged in?" kinda question, but it's all I can think of and I have to ask. The setting wheel on the P1, the clear wheel with the numbers, has an OFF position. You did set this wheel to a firing setting right?

Also, if I remember right, it won't fire unless the sight is raised.
 

Johnny Adama

New Member
No that's ok, I take no offense for an honest query.
Here is what I have done so far.
-fresh batteries
-phaser one by itself
-phaser one and two connected
-adjusting all switches and attempting to fire the gun in all positions.

So far nothing. Not a sound or light unless that plastic store display tab is plugged into it.
 

Johnny Adama

New Member
It was a Christmas gift, so I don't personally have the receipt. I'm not even sure where it was purchased from to be honest.
Perhaps I'll try to contact Art Asylum/Diamond Select and see what sort of insight they have into this.
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

rebelyell

Active Member
I recently had a communicator with the same issues. Never could figure it out and had to return it. Diamond Select may have a contact number on the package. Might try giving them a call.
 

Don't want to see this ad? Sign up for anRPF Premium Membershiptoday. Support the community. Stop the ads.

Top